[INCIDENT] Latency on our web's platform
Incident Report for Shippeo
Resolved
The incident has been resolved, and our service has returned to normal.
Posted Feb 26, 2024 - 10:59 CET
Investigating
Dear users,
We are experiencing a problem that is causing delays in loading data on our website. Our team is currently working on a solution to resolve this issue promptly.
Thank you for your understanding.
Posted Feb 26, 2024 - 09:17 CET
This incident affected: Web platform.